Difference between revisions of "Transition to Gadi"

(Access to projects)
Line 9: Line 9:
 
If you are using the conda environments under /g/data/hh5/public/modules, you need to request membership of the hh5 project if not already done. [https://my.nci.org.au/mancini/project/hh5 Here].
 
If you are using the conda environments under /g/data/hh5/public/modules, you need to request membership of the hh5 project if not already done. [https://my.nci.org.au/mancini/project/hh5 Here].
  
== Climate Models ==
+
== Models not supported by CMS ==
 +
You should try and update the library your model is using to the versions that will be installed on Gadi as much as possible.
 +
Then test if your model is compiling and working with the updated libraries
 +
 
 +
 
 +
== Climate Models supported by CMS==
 
=== WRF ===
 
=== WRF ===
 
Some issues appeared when compiling WRF with OpenMPI v4.0.1. These are being worked out.
 
Some issues appeared when compiling WRF with OpenMPI v4.0.1. These are being worked out.

Revision as of 23:05, 27 October 2019

This page presents information specific to CLEx users and the status of the models supported by CMS.

The main source of information for Gadi is hosted on NCI help pages: Preparing for Gadi. This page will only list additional, specific information. Please continue to refer to NCI's pages for main information.

Access to projects

On Gadi, there will no public access to any project. Additionally, only members of a project can access this project's filesystem space in jobs submitted to the HPC nodes.

conda environments

If you are using the conda environments under /g/data/hh5/public/modules, you need to request membership of the hh5 project if not already done. Here.

Models not supported by CMS

You should try and update the library your model is using to the versions that will be installed on Gadi as much as possible. Then test if your model is compiling and working with the updated libraries


Climate Models supported by CMS

WRF

Some issues appeared when compiling WRF with OpenMPI v4.0.1. These are being worked out. WRF is currently running on raijin with OpenMPI v2.1.3 so it is likely to run smoothly with other OpenMPI versions that will be installed on Gadi. We cannot test before access to Gadi.

NUWRF

NUWRF is being ported to Gadi with NCI's help. We expect a working solution will be ready shortly after Gadi is available.